Ambiente clicksign-demo fora do ar
Incident Report for Clicksign
Resolved
Ambiente restaurado.
Posted 10 months ago. May 02, 2018 - 13:06 GMT-03:00
Investigating
We are currently investigating this issue.
Posted 10 months ago. May 01, 2018 - 23:49 GMT-03:00